Keystroke / Keyboard Shortcut Guide

K0007

Use keyboard shortcuts to reduce the time it takes to draw and operate SpoolFab.

Keystroke Guide

The following apply while a drawing is displayed and no menu is active. You may sometimes have to press ESC to clear an active menu or ENTER to complete a task in process in order to get a response to these keystrokes.

File Menu

Ctrl+N    New Drawing
‍Ctrl+O   Open Existing Drawing
‍Ctrl+S    Resave
‍Ctrl+P    Print Drawing

Ctrl-PgUp    Switch to previous drawing in alphanumeric order
‍Ctrl-PgDn    Switch to next drawing in alphanumeric order

‍PgUp    Switch to previous drawing on the current list – no effect if no current list
‍PgDn    Switch to next drawing on the current list – no effect if no current list

Alt-PgDn    Switch to page 2 of current drawing
‍Alt-PgUp    Switch to page 1 of current drawing Note there are no items on page 2, just maybe BOM or weld list.

Edit Menu

F11    Item select mode, select pipe and fittings by clicking on tags
‍F12   Other select mode: select notes, images, details and draw-your-own details by drawing a box around them. Same mouse cursor as above.

Ctrl+X    Delete last item drawn
‍Ctrl+A    Select All
‍Ctrl+C    Copy selection Delete Delete selection
‍Ctrl+E     Edit Bill of Materials, also used to enter heat numbers or user codes
‍Ctrl+M    Reset Item Labels
‍Ctrl+W   Create/Show Weld Map
‍Ctrl+R    Reset Weld Tags
‍Ctrl+T     Edit Weld Tags, brings up window also used to enter Welder IDs, weld dates, assign welding lots and enter NDE results Dimension menu

‍F6    Place dimension to locate branch or accessory
F7    Dimension offsetbox
F8    Place miscellaneous dimension (Don’t use this to locate branches)Tools menus
F9    Get into Move mode to move item tags and weld tags

‍Ctrl+Q    Change Quantity. Click on the item tag to change quantity. For miscellaneous items you can also edit description, weight, and surface area.

Ctrl+F    Custom Fitting Dimension. Click on the mid-arm of an item to custom adjust that arm. Note that valves have two arms.F4 Redraw to refresh the display.

Ctrl+G    Update Weld Gaps. Sets weld gaps in accordance with the spec. This is useful if you change the weld gap settings in the spec.

Ctrl+J    IDF/PCF Adjustments. Used interactively when importing IDF or PCF files. Lets you indicate which pipes you want to be longer or shorter. Then press enter to reimport with the new settings. You can do this repeatedly until you get the proportions you want. If you can’t get a good arrangement, use Set, North Arrow Direction to view from a different angle.

Ctrl+Z    Put Shop welds on clipboard. This is especially useful on Installation drawings, where weld maps include only field welds. Usually after pressing Ctrl+Z, you create a note and paste the list of shop welds into it.